Problems with checkout purchases in the US
Incident Report for Status - North America
Resolved
Problem is resolved now and purchases are being processed flawlessly.
Posted over 1 year ago. Oct 29, 2015 - 10:58 CET
Monitoring
Service has been recovered and we will keep on monitoring it to make sure it's totally stable. Purchase flow is working fine again.
Posted over 1 year ago. Oct 29, 2015 - 10:54 CET
Investigating
We are facing some problems with checkout purchases in the US and investigation is ongoing. At the moment customers can't reach the checkout page.
Posted over 1 year ago. Oct 29, 2015 - 10:28 CET