Transatlantic internet connection issues
Incident Report for Status - North America
Resolved
Internet provider has confirmed there was an issue with the transatlantic connection. Everything is back to normal now.
Posted 3 months ago. May 02, 2017 - 17:14 CEST
Monitoring
Our services have been affected by a transatlantic internet connection interruption. We are monitoring the situation.
Posted 3 months ago. May 02, 2017 - 17:06 CEST