Problem with Card Payments affecting all countries
Incident Report for Status - North America
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 12, 2016 - 05:05 CEST
Investigating
We are currently experiencing issues with Card Payments in live environment. Purchases and payments with Card are not possible at the moment. We are investigating the issue.
Posted over 1 year ago. Apr 12, 2016 - 04:30 CEST