Merchant GUI issue and orderhandling
Incident Report for Status - North America
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 02, 2016 - 01:48 CEST
Investigating
We see some issues with the orderhandling, investigation is ongoing
Posted over 1 year ago. Apr 02, 2016 - 01:09 CEST
Monitoring
The services is working again and we are monitoring the situation
Posted over 1 year ago. Apr 02, 2016 - 00:55 CEST
Investigating
We are currently experiencing an issue with the merchant GUI in the live environment and orderhandling. We are investigating the issue.
Posted over 1 year ago. Apr 02, 2016 - 00:33 CEST