We are experiencing disturbances with the system Klarna Checkout.
Incident Report for Status - North America
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 20, 2016 - 15:54 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. Jun 20, 2016 - 14:57 CEST
Identified
We are experiencing Klarna Checkout disturbances
We are experiencing disturbances with the system, affecting primarily Klarna Checkout. We are investigating and will come back with more information.
Posted about 1 year ago. Jun 20, 2016 - 14:52 CEST