Order management issue
Incident Report for Status - North America
Resolved
The issue is resolved. We are back to normal operation.
Posted 11 months ago. Aug 30, 2016 - 16:47 CEST
Investigating
We are currently experiencing an issue with order management in the live environment. We are investigating the issue.
Posted 11 months ago. Aug 30, 2016 - 15:20 CEST