Klarna Checkout service issue
Incident Report for Status - North America
Resolved
The issue is resolved after some connectivity issues. We are back to normal operation.
Posted 10 months ago. Dec 06, 2016 - 21:37 CET
Investigating
We are currently experiencing an issue with the Klarna Checkout service in the live environment. We are investigating the issue.
Posted 10 months ago. Dec 06, 2016 - 21:33 CET