We are experiencing order management disturbances.
Incident Report for Status - North America
Resolved
The issue is resolved. We are back to normal operation.
Posted 11 months ago. Nov 09, 2016 - 14:05 CET
Investigating
We are experiencing order management disturbances.
We are experiencing disturbances with the system, affecting primarily order management. We are investigating and will come back with more information.
Posted 11 months ago. Nov 09, 2016 - 10:07 CET