Network issues in US
Incident Report for Status - North America
Resolved
The network problem is now resolved and all services are working flawlessly again. Incident is closed.
Posted almost 2 years ago. Nov 29, 2015 - 12:52 CET
Investigating
We are experiencing some network issues at the moment and many of our services are not responding properly. Investigation is ongoing in order to resolve the issue as soon as possible.
Posted almost 2 years ago. Nov 29, 2015 - 12:40 CET