Issues with TX in the US
Incident Report for Status - North America
Resolved
Services have been working nicely since when the actions were taken. We consider the incident as resolved.
Posted almost 2 years ago. Dec 01, 2015 - 21:41 CET
Monitoring
We had an issue with TX in the US now, which affected some services such as MyKlarna and Payment Gateway. Payments with card were delayed during the incident. Problem was identified and resolved already. The services are being monitored now.
Posted almost 2 years ago. Dec 01, 2015 - 20:51 CET